PHP: Hypertext Preprocessor, commonly referred to as PHP, is a famous open-source scripting language, which can be used to build dynamic sites with interactive features such as message boards, online learning websites or social networking websites. In stark contrast with static HTML-based websites, a PHP site can display unique web content to each user under the same exact page URL. Due to the fact that PHP-based web-based apps can be managed through a Control Panel, which you can sign in to using any Internet browser, you will not need any programming experience or practical experience whatsoever in order to administer a PHP-driven website. The fact that 100s of millions of websites around the globe are PHP-based is an indication of the language’s popularity and ease of use. You only ought to ensure that the web server where you host your website supports the exact same version of PHP as the one that you used whilst setting up the website.

PHP 4 and PHP 5 Support in Shared Hosting

We have made a conscious decision not to prevent our current and prospective customers from selecting the PHP version that their websites will be using, which suggests that in case you order a shared hosting plan from us, you’ll be able to select between versions 4, 5.2, 5.3, 5.4 and 5.5, not only for the account as a whole, but also for each individual domain hosted by you. This can be done with just one single click through our custom Hepsia hosting Control Panel via which all web hosting accounts are managed, which is why you will not have to possess any technical or programming capabilities. You’ll be able to host sites built with both new and old PHP scripts without having to cope with any obstructions, so if you’d like to abandon your current web hosting vendor and move over to us, you can be sure that all the websites that you have set up over the years will continue to run faultlessly.

PHP 4 and PHP 5 Support in Semi-dedicated Servers

In case you have a site built with a previous version of PHP and you have poured time and efforts into developing it, plugging safety holes and posting web page content, you’ll need a hosting service that can support it, since the majority of hosting suppliers nowadays support only the most recently released version of PHP and drop the previous versions. We, however, have decided to let you choose the exact version that your very own websites require. Our semi-dedicated plans support multiple versions of PHP 5 as well as PHP 4, which implies that you will be able to run both older and newer scripts without losing any manual tweaks or wasting time and efforts striving to make your sites compatible with the hosting platform. You can change the version via the Hepsia Control Panel and such a change will affect the whole account, but you’ll also be able to specify a different version for each site hosted in your account by means of an .htaccess configuration file.